[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Proposal: conversion functions

This page is part of the web mail archives of SRFI 101 from before July 7th, 2015. The new archives for SRFI 101 contain all messages, not just those from before July 7th, 2015.

Taylor R Campbell wrote:
   Date: Fri, 18 Sep 2009 17:09:48 -0400
   From: David Van Horn <dvanhorn@xxxxxxxxxxxxxxx>

Here is a proposal for converting between representation of pairs and lists.

I think the names PAIR->PAIR and LIST->LIST are very confusing.  Also,
both directions are necessary.  How about using more descriptive, if
more verbose names, such as SEQUENTIAL-LIST->RANDOM-ACCESS-LIST or
LINEAR-LIST->RANDOM-ACCESS-LIST?  Also, are the pair-only operations

As proposed, they do go both directions. I suspect the pair only operation is not useful, but I'm not sure. I will punt on that one for now. As for names, I like list->list; it's suggestive of it potentially being an identity operation, but I'd like to hear what others think.