[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Proposal: conversion functions



   Date: Fri, 18 Sep 2009 17:09:48 -0400
   From: David Van Horn <dvanhorn@xxxxxxxxxxxxxxx>

   Here is a proposal for converting between representation of pairs and 
   lists.

I think the names PAIR->PAIR and LIST->LIST are very confusing.  Also,
both directions are necessary.  How about using more descriptive, if
more verbose names, such as SEQUENTIAL-LIST->RANDOM-ACCESS-LIST or
LINEAR-LIST->RANDOM-ACCESS-LIST?  Also, are the pair-only operations
useful?