This page is part of the web mail archives of SRFI 99 from before July 7th, 2015. The new archives for SRFI 99 contain all messages, not just those from before July 7th, 2015.
Ray Blaak wrote:
Ray Blaak wrote:I am ignorant of some of the passed record systems referenced, so "rtd" does not seem obvious to me. "Record Type Data"?Ok:<definition> -> <record type definition> Nevertheless, my suggestion still stands. For all the helper record methods and forms, something that more directly reads as being record related would be better than "rtd".
I suggest stating that notational conventions of R6RS Ch 6 are followed and that /rtd/ is used for parameter names to indicate the corresponding argument must be a record type descriptor.
For the parameter convention, rtd seems appropriate. For names of values, I personally would prefer replacing rtd with type-descriptor or record-type-descriptor in any binding name . I would rather have informative names than brief names in a standards document. In actual code, it is easy to establish short abbreviations via renaming.
On the other hand, perhaps consistency with R6RS names should trump this preference.
David The latter leads to the appearance of redundancy in the name record-record-type-descriptor. The former might worry people by leaving the word "type" out there, unchaperoned, at the beginning of an identifier.