[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
record-mutator vs record-modifier
Many of the names of the procedural layer match those of
the "record" feature in SLIB, which I believe is based on
Pavel Curtis 1989 proposal.
(Some of these functions are different, but I believe an
implementation could overload both the old and the new specifications.)
However, SRFI-76 uses record-mutator where SLIB uses record-modifier.
Is there any reason for the for this difference? I think that the
old name is better than the new name, so why change it? I gues the
word "modifier" is somewhat overloaded (it could also be something
like an adjective or adverb that modifies some other action), but
at least it's a "real word", unlike "mutator". The arguments either
way don't seem strong either way, which argues for using the old name,
especially given that other record-XXX functions keep the old names.