This page is part of the web mail archives of SRFI 72 from before July 7th, 2015. The new archives for SRFI 72 contain all messages, not just those from before July 7th, 2015.
On 8/9/05, Keith Wright <kwright@xxxxxxxxxxxxxxxxxx> wrote: > > To avoid confusion, and make it easier to write portable > programs, it would be better to have distinct names for > these two distinct pairs of procedures. Then maybe one > could be defined in terms of the other. I don't know > if this would be possible, it would probably be slow, > but it is certainly more difficult if the two pairs of > procedures have the same names! > > Since the defining characteristic of the SRFI system is that > there are no special syntax objects, just lists of > identifiers, they might be called |datum->syntax-list| and > |syntax-list->datum|, or just go back to the original > shorter names. > I strongly agree. Besides "datum->syntax"/"syntax->datum" is shorter and doesn't look less intuitive to me than the "-syntax-object" names (because, as Keith already pointed out, they don't really deal with distinct syntax objects, but with s-expressions - albeit in a syntactic context). cheers, felix