[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

naming convention for non-exported names



The srfi-64 reference implementation testing.scm is rather
inconsistent about how to name "private" functions and macros:
test-evaluate-with-catch%
test-%any-specifier-matches
I don't have any strong feeling, but if there is a commonly-used
convention, I'd like to use it.  We could also use the form:
%test-some-name
or
test%-some-name
as well as the currently-used variations:
test-%some-name
test-some-name%
--
	--Per Bothner
per@xxxxxxxxxxx   http://per.bothner.com/