[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: feedback

This page is part of the web mail archives of SRFI 54 from before July 7th, 2015. The new archives for SRFI 54 contain all messages, not just those from before July 7th, 2015.

From: soo <tilde@xxxxxxxxxxx>
Subject: feedback
Date: 28 Mar 2004 20:58:51 +0900

>  | Having two distinct procedures at least help a programmer
>  | to express the intention.
> At present, I partially agree with you.
> How about adding <show> parameter to number type?
> Then you can write it like this:

My intention was to show just one example of the potential
consequences of overloading two functionalities on the same
function name.  The similar problem would arise for any
of those conflicting arguments such as an integer as <depth> vs <count>,
or 'd as <radix> vs <case>.  Unless you make "fmt for number"
upper-compatible to "fmt for object" (since a number is an object),
you can't write a function which is agnostic to its argument.