[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Making the new let easier to stomach
Many thanks for creating SRFI 5. Two comments:
- You're essentially arguing for replacing R5RS let with the one you
propose. This is totally valid.
As it SRFI, your proposal is still only a suggestion for an addition
to the language. Why not rename it to something other than let?
This would also make it easier to use for people dealing with legacy
- Is there a way to define the construct using standard R5RS macros
rather than explicit renaming (which is only supported by one or two
Cheers =8-} Mike
Friede, Völkerverständigung und überhaupt blabla