[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

constructor naming



Why was the constructor renamed to CREATE-ARRAY?  Everywhere else it's
MAKE-foo: R5RS's MAKE-VECTOR & MAKE-STRING, SRFI 1's MAKE-LIST, SRFI
25's MAKE-ARRAY, et cetera; I think that CREATE-ARRAY breaks a lot of
consistency.  I didn't see any consensus on renaming on this mailing
list, either...