[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]


This page is part of the web mail archives of SRFI 44 from before July 7th, 2015. The new archives for SRFI 44 contain all messages, not just those from before July 7th, 2015.

On Tuesday, April 29, 2003, at 04:07 PM, Taylor Campbell wrote:

The REMOVE in the middle of a function name has by convention in past SRFIs indicated a predicate argument, while DELETE indicates a simple value deletion. This, I believe, should be reflected in ITERATOR-REMOVE-VALUE!, as it already is
reflected in *-DELETE!.  I therefore propose to change it to

Er, and not just ITERATOR-(REMOVE->DELETE)-VALUE! -- also for things like
*-REMOVE!, *-REMOVE-ALL!, et cetera.