This page is part of the web mail archives of SRFI 43 from before July 7th, 2015. The new archives for SRFI 43 contain all messages, not just those from before July 7th, 2015.
Finally getting a bit of breathing space, so I am... "Michael Burschik" <Burschik@xxxxxxxxxxxxxxx> writes: > 4.5 Iterators > > If vector-unfold is the fundamental vector constructor, it should be > defined in 4.1 and not 4.5. Moreover, vector-unfold is hardly a > suitable name for a constructor. As the function is similar to "do" > returning a vector, the syntax might be changed to reflect this > similarity. On the other hand, this would break the similarity to > SRFI-1. So what? My issue with vector-unfold is that the unfold combinator isn't terribly efficient for fixed-length collections (and no, I don't particularly like the SRFI-13 string-unfold, either). And anyway, having lived with SRFI-1 unfold for a couple of years now, I have just about completely abandoned it in favor of named let; which is simpler to code with and more flexible anyway... > Given a not too inefficient implementation of vector-reverse, which > should be possible, the whole issue of left/right iteration would seem > rather pointless. Actually for vectors having the different left/right iterators is more important because a reverse is entirely unnecessary. It's just a decrementing integer loop instaed of an incrementing one. There's a big efficiency gain here. david rush -- Einstein said that genius abhors consensus because when consensus is reached, thinking stops. Stop nodding your head. -- the Silicon Valley Tarot