This page is part of the web mail archives of SRFI 34 from before July 7th, 2015. The new archives for SRFI 34 contain all messages, not just those from before July 7th, 2015.
>>>>> "Manuel" == Manuel Serrano <Manuel.Serrano@xxxxxxxxxxxxxxx> writes: Manuel> [...] was against some of the first Olin's SRFI Manuel> (at least SRFI-1 I think) that was overriding functions definitions Manuel> of Scheme R5Rs. Now, it is not question to override a Scheme definition but Manuel> it is question to override a Bigloo definition. May be it is only a concern Manuel> for Bigloo users but it is a real one. I see your problem, but I don't know that there's a way to avoid it in general: Sure, Olin could have avoided re-defining R5RS-bound names---R5RS is a published specification. But how can you avoid choosing a name chosen by the author of some Scheme implementation that's out there? There's no formal registry, there are dozens and dozens of them, and new ones are sprouting about every other month. Of course, Bigloo is more mature and more high-profile than most others, but that's beside the point in this context. Moreover, Scheme implementors are as likely to choose intuitive names as SRFI authors, as with TRY. Unfortunately, the whole naming issue with exception systems is a veritable mine field as there are so many names to choose from or to avoid, depending how you look at it. Carrying through your argument means that any Scheme implementor can effectively hijack any names she wants and argue against a SRFI (or some other library mechanism) choosing that name as well. (Technically, I'd say that a module system should be able to deal with this kind of problem easily, but that's again not the main point here.) Manuel> I don't think that it is possible to change Bigloo to add a new Manuel> semantics for try. The problem is not of how to implement it (it could Manuel> feasible). The problem is that it is a bad thing to have two different Manuel> semantics for one unique form. I have hated so long the Caml syntax Manuel> that used to provide two forms from writing the same expression (LET Manuel> vs WHERE), not to add now two semantics with one unique name in Bigloo Manuel> :-) I see only bad reasons for trying to do so. Richard and I are fully willing to change the name if we have an alternative that we agree with. He hasn't argued against changing the name in principle, he only argued against TRY/CATCH. So I'd say keep the suggestions coming. -- Cheers =8-} Mike Friede, Völkerverständigung und überhaupt blabla