[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Please rename TRY to something else



Hello Richard, hello every body

> But when I see 'try/catch' I have no idea what it is supposed 
> to do.  If the only conflict for "try" is Bigloo I am inclined
> stick with with it.  Because of the different arities there is
> no technical problem with implementing both.  It might cause
> some minor confusion for an occational Bigloo user, but the
> alternatives have the potential for confusing everyone.
All this remind me the exact reason why I have given a talk at the
Scheme workshop 2000 in Montreal that was more or less titled
"why I don't like SRFIs". I had several complains against SRFI
but my main concern at that time, was against some of the first Olin's SRFI
(at least SRFI-1 I think) that was overriding functions definitions
of Scheme R5Rs. Now, it is not question to override a Scheme definition but 
it is question to override a Bigloo definition. May be it is only a concern
for Bigloo users but it is a real one. 

I don't think that it is possible to change Bigloo to add a new
semantics for try. The problem is not of how to implement it (it could
feasible). The problem is that it is a bad thing to have two different
semantics for one unique form. I have hated so long the Caml syntax
that used to provide two forms from writing the same expression (LET
vs WHERE), not to add now two semantics with one unique name in Bigloo
:-) I see only bad reasons for trying to do so.

Sincerely,

-- 
Manuel