[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Please rename TRY to something else



>   From: "Manual Serrano" <Manuel.Serrano@xxxxxxxxxxxxxxx>
> 
>   I will have a look at the specification but first of all, let me ask you
>   a favor. Bigloo is already using TRY. It is already a special form for
>   Bigloo. Please give me a chance to implement SRFi-34 by renaming this form. 
> 
> The Bigloo form takes two arguments and SRFI-34's takes three, so
> there should be no technical problem with implementing both.  It
> would be a bit ugly.
> 
> Can you suggest another name?  
What about TRAP or BIND-ERROR (in the spirit of the old BIND-EXIT 
Dylan's form)? I will try to find other suggestions.

> TRY seems the natural one.
I agree this is why Bigloo uses it since the first released 
distribution.

-- 
Manuel