[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

would it be possible to change any of the function names?



greetings,

beeing very late in joining this dicussion i would like to excuse
myself for make these kind of big, but not very constructiv,
suggestions. those readers happy with the function names in the current
proposal need not read further.


i have no objection to the functionality/set of operations offered by
the "Integer Bitwise-operation Library" by Olin Shivers. instead i
would like to change function names and argument order to make them
slightly more reminiscent of the string and vector operations.


1 would it be possible to change

arithmetic-shift i count -> exact-integer

to

bit-shift-left i count -> exact-integer
bit-shift-right i count -> exact-integer


2 would it be possible to change

bit-set? index i -> boolean
any-bits-set? test-bits i -> boolean
all-bits-set? test-bits i -> boolean
first-set-bit i -> exact-integer

to

bit-set? i index -> boolean
bit-set-any? i test-bits -> boolean
bit-set-all? i test-bits -> boolean
bit-set-smallest i -> exact-integer


3 would it be possible to change

extract-bit-field size position i -> exact-integer
test-bit-field?   size position i -> boolean
clear-bit-field   size position i -> exact-integer
replace-bit-field size position new-field i -> exact-integer
copy-bit-field    size position from to     -> exact-integer

to

bit-field-extract i size position -> exact-integer
bit-field-test?   i size position -> boolean
bit-field-clear   i size position -> exact-integer
bit-field-replace i size position new-field -> exact-integer
bit-field-copy   from to size position     -> exact-integer


4 i have been unable to find a better name for

integer-length i -> nonnegative-exact-integer

but would really like to have a 'bit' prefix here too.


bengt