This page is part of the web mail archives of SRFI 25 from before July 7th, 2015. The new archives for SRFI 25 contain all messages, not just those from before July 7th, 2015.
I would suggest that "affine" would be a better name than "linear" for the properties of the access functions. Linear is OK (as in linear as opposed to quadratic polynomials), but in this context with all the "vector"s and "array"s, I think affine would be better. Also, instead of saying It is an error to store anything in an element of a shape. can one just say that "Shapes are immutable"? Brad Lucier