This page is part of the web mail archives of SRFI 17 from before July 7th, 2015. The new archives for SRFI 17 contain all messages, not just those from before July 7th, 2015.
>pps. let and letrec are both binding constructs. I don't see why we >need two different forms. Why not just use 'let,' and if any of the >right-hand-sides happen to refer to the name they're bound to, >implicitly change the whole thing into a letrec? I think this would >be much simpler and avoid lots of confusion. Personally I think this whole LET business is a wart (and probably inherited from BASIC, to boot -- good grief!) We should all be programming in CPS. --lars