[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
naming of string-trim, etc.
I'd like to propose a change that has no semantic effect on the SRFI,
just renaming of string-trim, string-trim-right and string-trim-both.
I think string-trim-both would be the most commonly-used of the three;
it should be named string-trim.
The string-trim-right procedure should be renamed because of the
left-to-right language assumption.
Note that in MIT Scheme (string-trim " hi ") ==> "hi".