[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
On 2013-10-20 12:26, John Cowan wrote:
> Alex Shinn scripsit:
> > How about renaming it "submatch"?
> > submatch?
> > submatch-string
> > submatch-start
> > submatch-end
> I think that's confusing if you aren't actually using submatches. I
> would favor either switching to "match" (and no, I don't think
> name collision is so important in this case), or using the explicit
> form "regexp-result", which describes what the object actually is.
I agree that this is confusing, even in the presence of "real"
submatches; you'd then have a submatch, with its own submatches
("subsubmatches"?), and no match to speak of. Some of the procedure
names would be OK, but as the record type name I don't think it's as
clear as "match".