[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
On 16/10/13 12:10, Alex Shinn wrote:
> I'm not too happy with the names myself though, but
> couldn't think of anything better. I'm open to other input.
I propose one of the following:
1. Rename the `rx-match` type (and related procedures) to "regexp-match",
and `regexp-match?` to "regexp-matches?" to avoid the new conflict.
("regexp-matches?" doesn't strike me as particularly better or worse
than "regexp-match?", but it is more clearly not a type predicate and
reads similarly to other procedures, viz. `file-exists?` or the proposed
2. Rename the `rx-match` type to "match" and leave `regexp-match?`
My very slight preference is for 2 -- the module system affords us the
freedom to use the more general names -- but I'd be happy with either.