[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: library separation

This page is part of the web mail archives of SRFI 114 from before July 7th, 2015. The new archives for SRFI 114 contain all messages, not just those from before July 7th, 2015.

On Mon, Dec 9, 2013 at 11:01 AM, John Cowan <cowan@xxxxxxxxxxxxxxxx> wrote:

> You're overloading "compare" to mean both the abstraction and ordered
> comparisons.  Could we rename the ordering to be something like "less"
> or "order"?

The abstraction is always called a comparator.

Right, I didn't say the term was used inconsistently,
but ambiguously.

Or do you mean to say the abstraction is consistently
"comparator" whereas the ordering function is consistently
"compare"?  I would still prefer they be separate.