This page is part of the web mail archives of SRFI 113 from before July 7th, 2015. The new archives for SRFI 113 contain all messages, not just those from before July 7th, 2015.
> Because it's a silly name. The term has always been "hash table"; > only Java (and C# which cloned Java) and R6RS use "hashtable", which > in English looks like "hasht-able" with the suffix "-able" added to a > nonexistent verb "hasht". I see your point, I've always considered hashtable as one word. Maybe I've got too used to Java way. > We are stuck with "bytevector" now, but there are still a lot of > programs using SRFI 69 and "hash-table". However, R6RS is standard and SRFI 69 is still SRFI. IMO, we should stuck with 'hashtable', especially if the hashtable APIs will be a part of R7RS. But this is off topic since it's not relative at all. Cheers, _/_/ Takashi Kato E-mail: ktakashi@xxxxxxxxx